Realtek RTL8187B funcionando en Ubuntu 7.10 (usando ndiswrapper)

Thomson TG123G wireless nicFinalmente, después de casi 3 meses, me han instalado mi nuevo Livebox de Orange… aunque la alegría duró poco… dos llamadas de casi media hora al 902 y sigo sin servicio.

Junto con el Livebox de Orange, viene una tarjeta de red WiFi USB marca Thomson TG123G. Como ya me está divirtiendo el tema de las tarjetas Wifi, he decidido configurarla para utilizarla en mi Ubuntu 7.10 (Gutsy Gibbon) utilizando ndiswrapper (aprovechando que ya estoy utilizando ndiswrapper para mi otra tarjeta).

A continuación detallo los pasos que he tenido que hacer:

1) Conectar la tarjeta USB y verificar el chipset que utiliza:

lspci | grep Ethernet

08:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

Podemos verificar el Product_id (0bda) y el Vendor_id (8189) mediante el comando:

lsusb

Bus 006 Device 007: ID 0bda:8189 Realtek Semiconductor Corp.

2) Instalar ndiswrapper. (sudo apt-get install ndiswrapper) Se puede instalar también la interfase gráfica ndisgtk. (sudo apt-get install ndisgtk)

3) Descargar los drivers correspondientes a la tarjeta RTL8187B para WinXP desde la página de Realtek:

http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=24&PFid=1&Level=6&Conn=5&DownTypeID=3&GetDown=false&Downloads=true

4) Extraer los archivos net8187b.inf y net8187b.sys correspondientes a WinXP (o WinXP 64 bits, si tenemos un procesador de 64 bits)

5) Instalar el fichero .inf en ndiswrapper, usando ndisgtk o mediante la línea de comandos:

 sudo ndiswrapper -i net8187b.inf

Screenshot ndisgtk
6) Guardar los archivos de configuración del módulo ndiswrapper mediante el comando:

sudo ndiswrapper -ma && sudo ndiswrapper -mi

7) Extraer la tarjeta USB y volverla a conectar. En este momento, podemos comprobar que se carga el módulo correcto viendo la salida del comando:

dmesg
[ 4508.604000] ndiswrapper: driver net8187b (Realtek Semiconductor Corp.,07/18/2007,5.1097.0718.2007) loaded
 [ 4512.124000] wlan1: ethernet device 00:18:e7:39:e9:63 using NDIS driver: net8187b, version: 0x1, NDIS version: 0x500, vendor: 'Realtek RTL8187 Wireless LAN USB NIC                                     ', 0BDA:8189.F.conf
 [ 4512.124000] wlan1: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK

Mediante el comando iwconfig podemos ver que ya nos aparece nuestra nueva tarjeta wifi.

Espero que esto sirva, como siempre, y si hay cualquier error o problema con estas instrucciones, por favor avísenme.

39 comments so far

  1. xir on

    Buenas!

    una preguntilla…a ver si me puedes ayudar: esto te funciona con un kernel SMP? resulta que mi sistema es de 64 bits puro, y parece que tan solo puedo instalar kernels SMP. Consigo que me instale el driver, pero el sistema se vuelve inestable y no consigo navegar. Alguna idea?

    Muchas gracias de antemano, un saludo.

  2. rofranco on

    Hola xir,

    No tengo ninguna máquina con dos procesadores donde hacer la prueba.
    Para darte alguna pista, necesitaría que me des más información: puedes conectarte a una red WiFi? La tienes correctamente configurada?

    Tambien puedes ver si tienes algún mensaje de error en la salida de dmesg.

    Suerte!!

  3. lusi on

    hey k onda, buen tuto pero no entendi lo del paso 4 despues de extraer esos 2 archivos que ago con ellos donde los pongo??

  4. rofranco on

    Hola Lusi,

    No se requiere dejarlos en ningun directorio en particular. Si vas a ejecutar el paso siguiente desde la linea de comandos, con “sudo ndiswrapper -i net8187b.inf” lo deberás ejecutar en el mismo directorio donde tengas los archivos.

    De todas formas, si no estás muy cómodo con la línea de comandos, probablemente te convenga usar el programa ndisgtk, el cual te permite de forma gráfica elegir los archivos (de la carpeta que sea) que quieras importar para ndiswrapper.

    Espero haberte aclarado las dudas.

    Suerte!!

  5. Antonio on

    Hola, estoy intentando instalar este mismo driver, y como veo que estás puesto en el tema me gustaría me ayudases si te és posible.
    mi maquina= toshiba satellite amd64 A210-19I, según veo en las propiedades de red en el win vista funciona la red wifi realtek RTL8187b, pero con ubuntu lo he intententado todo y no lo consigo, no sé que hago mál.Tengo instalado Ubuntu 8.04 beta amd64 y funciona todo de maravilla incluso el sonido que en la 7.10 no iba, ahora funciona bien pero la wifi ni siquiera la ve con iwconfig y el driver está bien instalado con ndisgtk me dice:net8187b, Hardware presente:si.
    Sin embargo no funciona, no me salen las redes inalambricas.
    Gracias de Antemano, llevo intentandolo y buscando por gogle y los foros más de un mes.
    tambien lo intenté con ubuntu 7.10 i386 y nada.
    Un Saludo.

  6. Ga-zor on

    Hola tengo Ubuntu gutsy en un hp pavilion y pues ami me da este error:

    [ 1808.760000] ndiswrapper (pnp_start_device:440): Windows driver couldn’t initialize the device (C0000001)
    [ 1808.760000] ndiswrapper (mp_halt:305): device f49ef500 is not initialized – not halting
    [ 1808.760000] ndiswrapper: device eth%d removed
    [ 1808.760000] ndiswrapper: probe of 2-6:1.0 failed with error -22
    [ 2158.136000] usb 2-6: USB disconnect, address 4
    [ 2161.972000] usb 2-6: new high speed USB device using ehci_hcd and address 5
    [ 2162.112000] usb 2-6: configuration #1 chosen from 1 choice
    [ 2162.236000] usb 2-6: reset high speed USB device using ehci_hcd and address 5
    [ 2162.380000] ndiswrapper (mp_init:263): couldn’t initialize device: C0010006
    [ 2162.380000] ndiswrapper (pnp_start_device:440): Windows driver couldn’t initialize the device (C0000001)
    [ 2162.380000] ndiswrapper (mp_halt:305): device f4b89500 is not initialized – not halting
    [ 2162.380000] ndiswrapper: device eth%d removed
    [ 2162.380000] ndiswrapper: probe of 2-6:1.0 failed with error -22
    [ 2469.992000] usb 2-6: USB disconnect, address 5

  7. rofranco on

    Respuesta para Antonio:

    Degraciadamente, lo único que puedo decirte es que comprendo tu situación y que en lo que pueda, intentaré ayudarte.

    Con la información que proporcionas no puedo saber mucho sobre el problema.

    Intenta mirar posibles mensajes de error del driver en la salida del comando dmesg o en el archivo /var/log/syslog

    Ahi puede que haya alguna pista de lo que pueda estar pasando.

    Suerte!!

  8. rofranco on

    Respuesta para Ga-zor:

    Viendo el mensaje que has adjuntado, parece ser que el driver que estás cargando no es el que corresponde a la tarjeta de red que tienes.

    Es muy importante que te asegures de que estás utilizando el driver correcto (fijate bien que en la página de mi enlace hay 3 drivers diferentes, y el que corresponde es el último (RTL8187B), que no tiene versión para Linux) y de que te asegures que el vendor_id y product_id de tu tarjeta sean los correctos, como explico en el post.

    Aparte de eso te doy otro consejo: si has instalado drivers de Windows Vista, prueba también con drivers de WinXP, o incluso Win 98, y con versiones 32 y 64 bits. Quizás probando encuentres el correcto.

    Si consigues solucionarlo, o si tienes más info, por favor coméntalo aquí para que te pueda ayudar o que todos aprendamos de otras soluciones.

    Gracias y suerte!!

  9. Rosa on

    Hola, y gracias por el artículo, pero después de instalar el driver y vuelvo a conectar el usb, el sistema se queda colgado ¿qué puedo hacer?

    Creo que sigo paso a paso tus indicaciones. Al principio el usb no se enciende y después de instalar los drives y volver a conectarlo, se enciende la luz pero como digo, se cuelga.

    ¿Me podrías ayudar?. Gracias.

  10. Rosa on

    Hola otra vez, pero mi problema ¿podría deberse a esto?:
    “Si tu caso fuese el famoso del Thomson TG123g, que al parecer usa el chipset rtl8187 [busca y trata de localizarlo con el comando lsmod e intenta bloquear la carga del mismo como he explicado anteriormente añadiéndolo a la “lista negra”, ya que de lo contrario te puedes encontrar con dos módulos intentando gestionar la tarjeta y eso no te funcionaría].” extraído de http://www.ambientix.org/2008/04/livebox-en-ubuntu.html

    Gracias y perdona mi abuso.

  11. Rosa on

    Hola otra vez, pero mi problema ¿podría deberse a esto?:
    “Si tu caso fuese el famoso del Thomson TG123g, que al parecer usa el chipset rtl8187 [busca y trata de localizarlo con el comando lsmod e intenta bloquear la carga del mismo como he explicado anteriormente añadiéndolo a la “lista negra”, ya que de lo contrario te puedes encontrar con dos módulos intentando gestionar la tarjeta y eso no te funcionaría].” extraído de http://www.ambientix.org/2008/04/livebox-en-ubuntu.html

    Gracias y perdona mi abuso.

  12. jorge on

    ola tengo un problema cuando coloco el comando lspci me muestra que tengo una tarjeta rtl8939 y cuando la verdad tengo una rtl8187 no hay forma de cambiar en algun lugar para colocar el verdadero tipo de tarjeta? muchas gracias de antemano por la ayuda

  13. rofranco on

    Hola Rosa,

    Puede ser que sea necesario añadir esto en el archivo /etc/modprobe.d/blacklist:

    blacklist ath_pci

    Prueba a agregarlo y reiniciar el sistema, a ver si ahora carga el módulo correcto.

    Coméntame luego si con esto te funciona.

    Muchas gracias por el comentario y suerte!!

  14. rofranco on

    Jorge,

    La verdad que me resulta muy raro lo que comentas.

    Si estás seguro de la tarjeta que tienes, se me ocurre que pruebes a seguir las instrucciones de este tutorial, y ver si se cargan correctamente los módulos.

    Saludos y suerte!!

  15. Daniel Valle on

    Hola que tal, recientemente instale ubuntu en mi lap top, pero tengo problemas con el wirless. Agradeceria mucho tu ayuda y comprención.

    EL modelo de mi Tarjeta es Realtek RTL8187B, solo que cuando meto el comando
    tecnotecario@tecnotecario-laptop:~$ lsusb
    Bus 007 Device 001: ID 0000:0000
    Bus 006 Device 002: ID 0bda:8197 Realtek Semiconductor Corp.
    Bus 006 Device 001: ID 0000:0000
    Bus 005 Device 001: ID 0000:0000
    Bus 004 Device 002: ID 0458:0036 KYE Systems Corp. (Mouse Systems)
    Bus 004 Device 001: ID 0000:0000
    Bus 003 Device 001: ID 0000:0000
    Bus 002 Device 001: ID 0000:0000
    Bus 001 Device 001: ID 0000:0000
    tecnotecario@tecnotecario-laptop:~$

    encuentro que es distinto el vendor_id.

    que puedo hacer. agradeceria me enviaras un mail a tecnotecario@hotmail.com muchas muchas gracias de antemano.

    Daniel Valle

  16. rofranco on

    Hola Daniel,

    Por lo que pude ver en Internet, parece que es la misma tarjeta que la que tengo yo, pero es la que viene interna en muchas laptop marca Toshiba.

    Puedes intentar seguir las intrucciones de este post, y si no te funciona, deberías probar con otras versiones de los drivers.

    Te dejo dos enlaces con instrucciones:
    Wireless in Toshiba A205-S5809
    Ubuntu Forums

    Si consigues que te funcione, por favor cuéntame cual es la manera correcta.

    Suerte!!

  17. Daniel Valle on

    Ok perfecto, muchas gracias por tu ayuda, ahora mismo probare las opciones que me brindas. te mantendre informado de mi situación.

  18. Hugo on

    Mira tengo una Toshiba Satellite A215, con tarjeta de red inalambrica RT8187b, tengo unbuntu 8.04 x64, ya he intentado de muchas maneras, instalar mi tarjeta de red, pero no logro hacer que la reconosca, instalo el driver, pero me dice que no hay hardware presente, ya lo cheque en windows que si es esa mi tarjeta, incluso lo cheque con el fabricante, tienes idea de que pueda estar pasando o como puedo solucionarlo??? Muchas gracias de antemano

  19. rofranco on

    Hugo,

    Intenta mirar posibles mensajes de error del driver en la salida del comando dmesg o en el archivo /var/log/syslog

    Ahi puede que haya alguna pista de lo que pueda estar pasando.

    Suerte!!

  20. NeIXeR on

    Hola, yo tambien tengo problemas con el wifi…

    Tengo un portatil toshiba L300 10Q.
    Antes que nada, menciono que para que cargase ubuntu hardy, tube que desabilitar de la BIOS el built-LAN (algo asi era). Ya que sino me salia un error y no me cargaba ni el Live CD. Pero al desmarcarlo consegui que iniciase y posteriormente instalar hardy completamente.

    Entonces, estoy sin conexion por cable ni wifi claro.

    Tengo RTL8187B
    aunque en lsusb me marca tambien:

    0bda:8197 Realtek Semiconductor Corp.

    He comprobado los drivers que utilizo en XP y son los 8187B. Asi que aqui tienen que ser los mismos.
    Pero nada, no consigo que funcione.
    Al poner iwconfig me muestra:

    lo no wireless extensions.

    He probado incluso el tema del blacklist y tampoco.

    Estoy revisando todo google, desde que me salia el error intentando instalar hardy en el portatil, y ahora continuo con el tema del wifi. Asi que aver si tenemos suerte y damos con la solucion.

    Saludos

  21. Oneiyo on

    Holaaaa, necesito el driver del thomson tg123g para windows xp. No lo encuentro por ningun sitio, por favor, si alguien sabe como conseguirlo, le agredeceria mucho q me contestara. Gracias

  22. rofranco on

    Hola Oneiyo,

    En el post tienes el enlace al driver del thomson tg123g para windows xp (de hecho es el que yo utilizo desde Ubuntu)

    De todas formas, te animo a que pruebes de usar sistemas libres, y no por una cuestión de dinero. Puedes leer más en esta entrada: https://quilombo.wordpress.com/2008/04/11/richard-stallman-en-madrid-free-as-in-freedom/

    Suerte!!

  23. Santi on

    Una cosa, el enlace que dan ahí no es para el 8187b, sino para otro, en éste si que hay para bajar el driver de 64 bits pero no en el 8187b, mi caso lógicamente es que tengo la version 8.04 de 64 bits y entonces necesito ese driver.

    ¿que hago? he probado con los demás driver para ndiswrapper.

    ya no se donde dar..

    gracias

  24. rofranco on

    Hola Santi,

    En la página del enlace, tienes que ir hasta abajo de todo. Ahi vas a ver una sección con drivers para el RTL8187B.

    Si descargas el ZIP verás que dentro hay versiones para 64 bits.

    Suerte!!

  25. mar on

    Yo tengo un macbookpro y no hay manera de hacerlo funcionar con wifi, además voy buscando los drivers para el thomson tg123g PARA MAC ..sigh sigh..help help

  26. rofranco on

    Hola Mar,

    Lamento no poder ayudarte… aunque siempre puedes instalar Linux en el Mac!!!

    http://ubuntuforums.org/showthread.php?t=198453

  27. mar on

    o mejor comprar la trajeta airport!gracias!!

  28. ricardo on

    Ya he logrado instalar la tarjeta wifi,solo que aun no me logro conectar a internet, como lo puedo lograr??, ya le indique el DNS, IP, y la clave wep.

    que otra cosa puedo hacer para conectarme a internet

  29. Ruben on

    Felicidades! Me ha funcionado a la primera!. Pero la instalación de ndiswrapper no me había funcionado desde la página de ndiswrapper y en cambio sí desde agregar programas de Ubuntu.

  30. rofranco on

    Me alegro de haberte ayudado!!!

  31. Ruben on

    Vaya me funcionó sólo una vez pero al reiniciar ahora no me conecta. Lo raro es que haciendo un iwconfig me coge ip y me sale la mac address del access point (router) pero cuando hago un ping al router no me lo coge. Estoy usando wifi-radar y wap y estoy poniendo que el driver del wap es ndiswripper. En el router tengo wap con tpik. Estoy usando xubuntu 8.04.

    • rofranco on

      Hola Rubén,

      Si al hacer el iwconfig aparece la tarjeta, entonces ya la tienes configurada correctamente.
      Pareciera que el problema lo tienes al poner los parámetros de conexion con el router… puedes intentar conectarte mediante WEP en lugar de WPA… es menos seguro, pero en general es más fácil.

      Por cierto, he visto tu web y te comento que desde hace un tiempo me estoy planteando dedicarme más de lleno a la formación a empresas, la consultoría y quizás algunos desarrollos.

  32. Ruben on

    Ei ya funciona🙂. Era un error en el hosts en la configuración manual de netkwork manager en el hosts que tenía mal puesto el domain. Al final configurando wifi-radar y network manager ya funciona mi portátil con ubuntu el famoso thompson y la WPA con filtrado de Mac address. Es una gozada este ubuntu!!!. Pues vamos la verdad es que con la crisis la cosa está flojilla. Cuando quieras estás invitado a una cervecita🙂.

  33. Ruben on

    Algo importante: he probado y descargado wicd en http://wicd.sourceforge.net/download.php y te sustituye al network manager de ubuntu. Va mucho mejor y más rápido. Lo curioso es que en el apartado wpa_supplicant hay que ponerle widnext en lugar de ndiswrapper para que me funcione mi tarjeta realtek. Los errores de network manager vienen reparados y mejorados en wicd. Alguna de las virguerías te autoconfigura la red si tienes el dhcp automático.

    • rofranco on

      Hola Rubén.

      Había oído hablar muy bien del Wicd… y con tu comentario me has animado a probarlo… ya te contaré!!

      Rodolfo

  34. david on

    oye, tengo un problema.. instala el driver y todo… y aparecen las redes inalambricas en la lista… pero a la hora de intentar conectarme solamente no jala! no se conecta, y estoy mas que seguro que es la contraseña correcta… xk mi otra compu si conecta!, si alguien tiene idea de que me pueda estar pasando, por favor ayudenme, gracias

  35. leidy on

    tengo un adaptador de red usb WLAN 802.11g que el windosw 7 me reconoce y me trabaja sin problema como (wireless RTL8187 802.11g), pero por mas driver que descarge no he podido instalar este usb en un sistema operativo XP SP2, ya he descargado los 3 archivos que me ofrece la paguina de Realtak, y otros tantos mas pero nada que responde, me gustaria saber donde mas puedo encontrar el driver propio para este sistema, o si se requiere de un paso que no conosco que me falte por hacer.
    gracias

  36. kanon on

    ola tengo un problema tengo una realtk rtl18187 alfa 1w y la quiero instalar en ubntu lo que pasa es que tengo windows y ubuntu pero la targeta esta instalada en windows y cuando m cambio a ubuntu el internet es super lento tardo como 15 minutos en abrir una paguina y la quiero instalar en ubuntu ya baje los drivers pero no se los comandos me podrian ayudar

    • rofranco on

      Hola kanon,

      Creo que lo que buscas está explicado en este enlace:
      http://factoriawireless.net/index.php?topic=389.0

      Los comandos que tienes que ejecutar están detallados… solamente tendrás que agregar “sudo” delante en algunos de ellos (puedes probar ejecutandolos tal como están y en aquellos que te dé error de permisos, le añades el “sudo” por delante) si estás trabajando con Ubuntu.


Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: